protocoles http(s) OK dans KFA mais ignorés selon le user

Vous avez rencontré un problème dans l'utilisation de la LiberKey ?
2 messages • Page 1 sur 1

protocoles http(s) OK dans KFA mais ignorés selon le user

Messagede eseborange » 04 Juin 2022, 18:42

bonjour à tous,

j'ai depuis peu un souci avec les associations de la Liberkey : sur mon poste principal (Windows 7 x64), cliquer sur un lien http ou https n'ouvre plus comme auparavant Firefox mais Internet Explorer. En creusant un peu plus, je me suis aperçu que le problème ne concernait que mon utilisateur Windows standard, et que cela fonctionnait avec mon utilisateur admin.

sur un autre ordinateur portable (même OS), cela fonctionne toujours pour les deux types d'utilisateurs (standard et admin).

Internet Explorer n'est pas explicitement défini comme navigateur par défaut sur les 2 postes.

- j'ai comparé les fichiers KeyFileAssoc.xml : la définition des protocoles http et https est strictement la même sur les deux postes (cela correspond sur KFA à Firefox défini par défaut, et l'option "remplacer les actions prédéfinies pour ce type de fichier" cochée).

lorsque les associations sont activées, on retrouve bien les options définies dans KFA dans la base de registre à plusieurs niveaux:

- HKEY_CURRENT_USER\Software\Classes

- HKEY_CLASSES_ROOT

- HKEY_USERS_<mon id>\Classes

- HKEY_USERS_<mon id>\Software\Classes

j'ai, en étant connecté sous l'un puis l'autre utilisateur, exporté ces clés et comparé le contenu des fichiers .reg avec WinMerge : pas de différences hormis dans HKEY_USERS mais ce sont uniquement les id des utilisateurs qui différent ce qui est normal.

voyez-vous une autre piste pouvant expliquer cette différence de comportement entre l'utilisateur standard et l'utilisateur admin utilisant la même Liberkey ?
eseborange
Fresh Boarder
Fresh Boarder
 
Messages: 26
Inscription: 07 Août 2017, 16:21

Re: protocoles http(s) OK dans KFA mais ignorés selon le use

Messagede eseborange » 04 Juin 2022, 22:06

j'ai trouvé la solution dans la section anglaise du forum :
https://www.liberkey.com/fr/forums/supp ... -5760.html

"For http/https protocols :
Open regedit.exe . And find the key HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations (added when Internet Explorer has been chosen) and rename it or delete it."

avec mon utilisateur standard, j'avais un moment configuré IE comme navigateur par défaut puis pensé avoir fait le nécessaire pour qu'il ne le soit plus (n'apparaissait plus comme tel dans les options internet) mais les associations dans la base de registre subsistaient et elles priment apparemment sur le paramétrage KFA.

(on peut se contenter de supprimer le Progid faisant référence à IE pour chaque protocole concerné, par exemple IE.HTTP pour le protocole http)
eseborange
Fresh Boarder
Fresh Boarder
 
Messages: 26
Inscription: 07 Août 2017, 16:21


2 messages • Page 1 sur 1

Retourner vers Support

Qui est en ligne

Utilisateurs parcourant ce forum: Google [Bot] et 125 invités

cron